About Store Forum Documentation Contact
Donations:
140$/mo



Post Reply 
Ubuntu 20.04 make basic app fails
Author Message
Lancer Offline
Member

Post: #1
Ubuntu 20.04 make basic app fails
Hello,

I'm trying to get esenthel to work on linux (ubuntu 20.04).
I've installed Ubuntu 20.04 on hyper-v manager.

Followed instruction on https://www.esenthel.com/?id=doc#Installation
Was able to install esenthel without any issues.

I opened the tutorial "(01 - Start ) 1- Basic App" and exported "C++ with Linux Make project".

Then I went to the folder and opened the terminal.
Wrote "make" and then I get some errors.

   

Did I forget something?
(This post was last modified: 02-26-2021 09:57 PM by Lancer.)
02-26-2021 09:57 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #2
RE: Ubuntu 20.04 make basic app fails
You can try installing the source edition instead, from github
02-27-2021 02:16 AM
Find all posts by this user Quote this message in a reply
Lancer Offline
Member

Post: #3
RE: Ubuntu 20.04 make basic app fails
I've compiled the engine and editor from source (windows).
But when I try to connect to the server, it says the version is different.
For server, I use Binary version (Linux/Ubuntu) from the download page.

In the system information page it says, Engine Build 65 and Editor Build 65.
Inside esenthelengine.h I have 68
(This post was last modified: 03-02-2021 04:21 PM by Lancer.)
03-02-2021 04:09 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #4
RE: Ubuntu 20.04 make basic app fails
Please recompile server from the source too.
03-02-2021 04:46 PM
Find all posts by this user Quote this message in a reply
Lancer Offline
Member

Post: #5
RE: Ubuntu 20.04 make basic app fails
I also have a weird issue with this.
I changed version to 68. But no matter how many times I build the engine + editor. It keeps saying editor version 67.

And it keeps saying there is a new esenthel version available.

- Update
nvm. My bad, I thought the new version box will only apply if the application version is lower than the website version.

Where do I find the source code for the Server ?
I found it.
It's the project h3kv^1fvcwe4ri0#ll#761m7
(This post was last modified: 03-02-2021 08:49 PM by Lancer.)
03-02-2021 05:11 PM
Find all posts by this user Quote this message in a reply
Post Reply