About Store Forum Documentation Contact
Donations:
140$/mo



Post Reply 
Particle and Object Loading Issue
Author Message
Aviticus Offline
Member

Post: #1
Particle and Object Loading Issue
I am trying to get particles and Destructible Objects to load in the MMO Demo Client. I have added the particle object that I want through the world editor.
I then added the following code:

Game::ObjMemx<Game::Item > Items; // container for item objects
Game::ObjMemx<Game::Chr > Chrs; // container for character objects
Game::ObjMemx<Game::ObjParticles > ParticleItems; // container for particle objects
Game::ObjMemx<Game::Destructible > DestructItems; //Container for Destructible Objects

Then I changed my InitGame method to look like the following:

Bool InitGame()
{
if(!ChrData.world())return false;

Sky.atmospheric();
Clouds.layered.set(3,Images("clouds/layers/0.gfx"));

Game::World.init ( )
.setObjType(Players,OBJ_PLAYER)
.setObjType(Statics,OBJ_STATIC)
.setObjType(Items ,OBJ_ITEM ) // set 'Items' memory container for 'OBJ_ITEM' objects
.setObjType(DestructItems,OBJ_DESTRUCTIBLE)
.setObjType(ParticleItems,OBJ_PARTICLES)
.New(ChrData.world()->worldDir());

Cam.setSpherical(ChrData.pos(),0,-0.7f,0,10);

Gui+=CMRegion.create(Rect_LD(-D.w()+0.05f,-D.h()+0.05f,0.75f,0.3f)); CMRegion+=CM.create();
Gui+=ChatLine.create(Rect_C(0,-0.8f,1.5f,0.06f)).maxLength(MAX_CHAT_LENGTH);
InvGui .create();
GameMenu.create();

return true;
}

When I start up my client and get into the world none of the particles or Destructible objects are visible.

is there something more that I need to go in order to get them working?
04-22-2011 09:28 PM
Find all posts by this user Quote this message in a reply
Post Reply