About Store Forum Documentation Contact
Donations:
140$/mo



Post Reply 
[SOLVED] Can't load azvw1^ptk#^5!_s_e9h3^sbq
Author Message
Pixel Perfect Offline
Member

Post: #1
[SOLVED] Can't load azvw1^ptk#^5!_s_e9h3^sbq
I've tried loading my test level for the first time today in code and depending on where I place the camera initially it either loads sucessfully or causes the above error.

It appears to be in the call to Game.World.update(Cam.at);

I assume it thinks this item is in the world but is failing to find it. I have tried searching for this item in the editor but nothing is returned, I can see no reference to this ID in the project or any of its subdirectories.

Is this something I've deleted/removed at some point that is still being referenced somewhere? In which case any idea where and how I can correct/remove the reference?
(This post was last modified: 03-23-2013 11:56 PM by Pixel Perfect.)
03-23-2013 06:26 PM
Find all posts by this user Quote this message in a reply
xzessmedia Offline
Member

Post: #2
RE: Can't load azvw1^ptk#^5!_s_e9h3^sbq
i had the same problem...
i can't really tell you how to resolve it, but it happens when you place objects in your world and after that you delete the object ressources, they will remain in the world but they are blinking red.

Royality Free Game Ressources
www.xzessmedia.de
03-23-2013 08:41 PM
Find all posts by this user Quote this message in a reply
Pixel Perfect Offline
Member

Post: #3
RE: Can't load azvw1^ptk#^5!_s_e9h3^sbq
Ah thank you, that's really helpful. I'll start looking!
03-23-2013 08:52 PM
Find all posts by this user Quote this message in a reply
Pixel Perfect Offline
Member

Post: #4
RE: Can't load azvw1^ptk#^5!_s_e9h3^sbq
Well I didn't find anything blinking red but I did manage to track it down. I'll post my steps for anyone else that may have the same issue in the future:

Used WinGrep with binary files selected to search my project directory for the missing ID. It was found in the Game Area -6,2 in my case.

Located that area on my level using the cursor in Terrain mode (gives xyz coords plus area info)

Switch from Terrain To Object tab and select all the items in the area by dragging the cursor around them

Click on the List button to display the list of objects

Found the missing item on the terrain as its identified as unknown (see screen shot below)

Click on item in list to highlight and delete ... job done!

   
03-23-2013 11:55 PM
Find all posts by this user Quote this message in a reply
Post Reply