About Store Forum Documentation Contact
Donations:
178$/mo



Post Reply 
Texts don't show
Author Message
Esenthel Offline
Administrator

Post: #16
RE: Texts don't show
The warning is also irrelevant.
Yes I know the problem is still occurring.
I've asked AMD to investigate because I don't see any problem on the engine side.
10-28-2019 03:56 PM
Find all posts by this user Quote this message in a reply
notmyaccount Offline
Member

Post: #17
RE: Texts don't show
when i set sub_pixel to true, i have this effect: https://imgur.com/a/NeHNiI8
(This post was last modified: 10-29-2019 12:45 PM by notmyaccount.)
10-29-2019 12:25 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #18
RE: Texts don't show
AMD was able to reproduce the bug and it was sent to their internal driver team for further investigation. I was told even if they confirm it as a bug and fix it, the driver may take few weeks/months until it's released to public.

So once I finish PBR, I will try to make a workaround for next release.
10-31-2019 05:23 AM
Find all posts by this user Quote this message in a reply
Zervox Offline
Member

Post: #19
RE: Texts don't show
This news is a carrot and stick if there ever was one. pfft but good thing they atleast managed to also reproduce it.
10-31-2019 07:08 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #20
RE: Texts don't show
I've just uploaded a new engine version with a possible workaround for AMD problem.
Could anyone with AMD card please test it?
Thank you
12-03-2019 03:49 AM
Find all posts by this user Quote this message in a reply
Zervox Offline
Member

Post: #21
RE: Texts don't show
Sadly doesn't work for me atleast, 19.10.1 and 19.12.1 tested
12-03-2019 04:09 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #22
RE: Texts don't show
1)
I use this code to detect AMD card, could you please tell me if when putting this code into any of the tutorials:
Code:
Bool Init()
{
  Exit(ContainsAll(D.deviceName(), "AMD Radeon", true, true));
  ...
Does it properly show 1 (and not 0) on your computer with AMD card?

2)
I've just uploaded another workaround, could you please try the newer version?
12-03-2019 05:54 PM
Find all posts by this user Quote this message in a reply
RedcrowProd Offline
Bronze Supporter

Post: #23
RE: Texts don't show
Good news grin
I have the latest version on my laptop that runs AMD (i had huge artifact in the last update) and it is now working well, im not 100% sure about the text itself, but so far everything seems normal.

The only issue i have so far is with my Nvidia, the deferred render in the editor is flickering like crazy with artifact that stays about a split second.

happens with any material when i look at it in the editor, and same with anything that uses that material ( world, obj ... ).

In the game itself tho, it is perfectly fine, it really only happens in the editor
(This post was last modified: 12-04-2019 03:48 AM by RedcrowProd.)
12-04-2019 03:32 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #24
RE: Texts don't show
thanks for letting me know smile
the flickering on Nvidia is probably a bug in the driver, I'm guessing related to Render Target Discard.
If it's get too annoying or other people have it, perhaps I could temporarily disable it.
12-04-2019 05:54 AM
Find all posts by this user Quote this message in a reply
Zervox Offline
Member

Post: #25
RE: Texts don't show
last fix worked perfectly in regards to text. smile

atleast no issue with flickering on deferred material viewing on my RX 5700, just to have it noted.
(This post was last modified: 12-04-2019 12:23 PM by Zervox.)
12-04-2019 12:17 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #26
RE: Texts don't show
(12-04-2019 03:32 AM)RedcrowProd Wrote:  The only issue i have so far is with my Nvidia, the deferred render in the editor is flickering like crazy with artifact that stays about a split second.
I've reported the bug to Nvidia:
https://devtalk.nvidia.com/default/topic...n-geforce/
12-21-2019 08:08 AM
Find all posts by this user Quote this message in a reply
RedcrowProd Offline
Bronze Supporter

Post: #27
RE: Texts don't show
oh yeah that's exactly the issue i had, glad? im not the only one :o
12-21-2019 04:32 PM
Find all posts by this user Quote this message in a reply
Post Reply