About Store Forum Documentation Contact
Donations:
140$/mo



Post Reply 
Swing detection tutorial fail
Author Message
Kaldrick Offline
Member

Post: #1
Swing detection tutorial fail
Oy there. I've been out for quite a time, but I've came back and wanted to have fun with new tutorials. But by the time I've compiled the Swing tutorial I found it broken. It renders everything perfectly, but the weapon does not move around. Anyone with similiar problem?
12-23-2009 07:15 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #2
RE: Swing detection tutorial fail
did you update the EsenthelEngine.lib? and headers?

what does this function draw on the screen during tutorial?
D.text(0,0.7,S+Tm.time());
12-23-2009 07:20 PM
Find all posts by this user Quote this message in a reply
Kaldrick Offline
Member

Post: #3
RE: Swing detection tutorial fail
Its stuck at 0.000. Lib and headers are to be updated manually? I thought auto-updater does that.
12-23-2009 07:21 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #4
RE: Swing detection tutorial fail
yes it does, but I want to make sure that they have been copied, could you verify that manually?
12-23-2009 07:22 PM
Find all posts by this user Quote this message in a reply
Kaldrick Offline
Member

Post: #5
RE: Swing detection tutorial fail
Aye, they are. May it be problem with VS 2010?
12-23-2009 07:23 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #6
RE: Swing detection tutorial fail
1 moment, I think I have this problem too, I'll check
12-23-2009 07:25 PM
Find all posts by this user Quote this message in a reply
Mikesanimation Offline
Member

Post: #7
RE: Swing detection tutorial fail
(12-23-2009 07:25 PM)Esenthel Wrote:  1 moment, I think I have this problem too, I'll check

Yes, this happens with mine, as well.
12-23-2009 07:26 PM
Find all posts by this user Quote this message in a reply
menajev Offline
Member

Post: #8
RE: Swing detection tutorial fail
I made update few minutes ago (I haven't done update for a couple of weeks) and have this problem with my game - Tm.d() always equals 0, although Tm.curTime() seems working without problems.
In addition I have some problems with VS, but I'll try to find out what's wrong myself (if I fail, I'll ask).
(This post was last modified: 12-23-2009 07:40 PM by menajev.)
12-23-2009 07:39 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #9
RE: Swing detection tutorial fail
I'll be uploading the fix in a minute
12-23-2009 07:42 PM
Find all posts by this user Quote this message in a reply
Mikesanimation Offline
Member

Post: #10
RE: Swing detection tutorial fail
Yes, that is definitely the problem. Tm.d() always is 0.
12-23-2009 07:43 PM
Find all posts by this user Quote this message in a reply
menajev Offline
Member

Post: #11
RE: Swing detection tutorial fail
Ok, I can't do that myself - http://up.k10x.net/ucuuiarpiuxmn/eebug.PNG - I see that every time i try to run game via VS, when I click icon i Explorer there is no problem. The same is with some tutorials (e.q. Physical Clothing), but there is no error - just black game's window and no way to turn it off in another way then killing Visual. But when clicking icon it starts without problem.
(This post was last modified: 12-23-2009 07:55 PM by menajev.)
12-23-2009 07:55 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #12
RE: Swing detection tutorial fail
I've uploaded the fix, please use the Autoupdate and try again
12-23-2009 08:00 PM
Find all posts by this user Quote this message in a reply
Post Reply