About Store Forum Documentation Contact
Donations:
158$/mo



Post Reply 
Application failed to initialize properly (0xc0000235)
Author Message
pOiO Offline
Member

Post: #1
Application failed to initialize properly (0xc0000235)
Hi when I try to run the hello world tutorial from visual c++ 2010 or 2008 I get this error: Application failed to initialize properly (0xc0000235). But the .exe is generated correctly that when I run it from windows explorer, it runs ok, but not from visual studio.

The only strange thing in my setup is that I link the .libs(esenthel and direct x) and the .h through project settings. Not by copy and paste the files to visual studio folders. I don't think it should be a problem. It worked like that before.

Im using Windows XP sp3, latest esenthel,direct x sdk june 2010. I have tried with visual c++ 2008 and 2010.

I'm missing something? Could it be an os settings issue?

I used to compile esenthel the same way.
12-09-2010 10:21 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #2
RE: Application failed to initialize properly (0xc0000235)
Hi,

The EE SDK doesn't require linking to DX SDK libs, in fact you shouldn't do it.

Please run autoupdate, and make sure libs and headers are copied to Visual Studio folders.

Please use the same project settings as in SDK\Tutorials (and documentation)
12-09-2010 10:45 PM
Find all posts by this user Quote this message in a reply
pOiO Offline
Member

Post: #3
RE: Application failed to initialize properly (0xc0000235)
Same results, the exe can't be runned from visual studio,but it can be runned from windows explorer.
12-09-2010 11:01 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #4
RE: Application failed to initialize properly (0xc0000235)
Are you using custom project or the one from latest SDK (tutorials.sln) ?
12-09-2010 11:21 PM
Find all posts by this user Quote this message in a reply
pOiO Offline
Member

Post: #5
RE: Application failed to initialize properly (0xc0000235)
Yes from the tutorials. I deleted the folder. Extracted it again. Paste the required files to the vc directories.Run autoupdate. I opened the tutorials sln file. Build and its ok. But when I run it from visual c++ it throws the error. But when I launch it from explorer it launchs ok. Maybe its my pc that can't debug the exe. Do I need to have a specific windows service on or something like that? Because I starting to think its my pc's fault.
12-10-2010 12:01 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #6
RE: Application failed to initialize properly (0xc0000235)
Well that sounds more like some visual studio/windows issue.
Did you tweak anything in the system?
Make sure to have all latest windows updates.
Also, try searching more at google.
12-10-2010 01:54 AM
Find all posts by this user Quote this message in a reply
pOiO Offline
Member

Post: #7
RE: Application failed to initialize properly (0xc0000235)
I had installed a program called NTuneup. I uninstalled it , and now it works.
Thanks for the help.
12-23-2010 04:21 AM
Find all posts by this user Quote this message in a reply
Post Reply