About Store Forum Documentation Contact
Donations:
158$/mo



Post Reply 
World Editor hanging on Thinkpad with ATI FireGL3200
Author Message
impi Offline
Member

Post: #1
World Editor hanging on Thinkpad with ATI FireGL3200
Hi,

I tried to download and install Essenthel on one of our developers IBM Thinkpad notebook to do some coding prototyping on Essenthel after hours. It's not a high-spec and older machine, but I would expect it to run as it has an ATI FireGL3200 (M24GL) - so supports DirectX 9, Shader 2.0, and has latest drivers.

The editor starts up and seems to work ok (just switching between the tabs for now) till we try access the World Editor. Then it just hangs and eventually we get a black screen and no response.

Is there anything we should do to get it running.

Thx
01-01-2012 02:51 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #2
RE: World Editor hanging on Thinkpad with ATI FireGL3200
I suspect it's the fault of the ATI FireGL 3200 driver.

What you can do - run some C++ tutorials in debug mode and see if you also have crashes, then with crash post some visual C++ callstack screens here.
01-02-2012 11:16 AM
Find all posts by this user Quote this message in a reply
impi Offline
Member

Post: #3
RE: World Editor hanging on Thinkpad with ATI FireGL3200
Thanks for reply.

A C++ debug build of tutorial succeeds and it runs without issue.

For some reason its only the 'World Editor' that crashes, the Model Editor for example is fine. So I guess that indicates its something specific in World Editor - so probably not something that would be found in a simple tutorial etc.
01-02-2012 04:44 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #4
RE: World Editor hanging on Thinkpad with ATI FireGL3200
WE uses more shaders, draws more things on the screen, lines, sun, etc.
It's possible that one of those things triggers the faulty ATI driver.
Without precise callstack I can't provide more help.
EE runs okey on all other hardware, dx10, dx9 (sm2.0 and sm3.0), opengl, opengl es, nvidia, ati, intel. So I can only keep on guessing that FireGL 3200 ATI has some bug in the driver (old ATI cards are well known for having those)
01-04-2012 10:04 PM
Find all posts by this user Quote this message in a reply
Post Reply