About Store Forum Documentation Contact



Post Reply 
Particle question
Author Message
Gian-Reto Offline
Member

Post: #1
Particle question
Stupid question maybe, couldn't find an answer with the search function though:

I'm trying to set up an particle effect for a cloud in the editor.

Now, when I use palette mode, the Image gets completly oversaturated, its unusable really. When I try to switch to blend mode, the particles dissappear.

I use an RGB Image with an alpha channel created in Phtotoshop, saved as .PNG .... could it be that I did anything wrong here?

Other question: How do I create a particle effect of slowly floating Cloud-particles? I don't seem to be able to switch of the finite live of the particles so they don't dissappear all the time, and I don't seem to be able to make them move around randomly.

Last question: If I want to use multiple images, I have to mix different particle systems, or use animated pictures, right?


Thanks for any help


Gian-Reto
02-04-2013 09:44 AM
Find all posts by this user Quote this message in a reply
Rabishan Offline
Member

Post: #2
RE: Particle question
after turning off palette mode did you add alpha value in the particle color.
02-04-2013 11:54 AM
Find all posts by this user Quote this message in a reply
Gian-Reto Offline
Member

Post: #3
RE: Particle question
(02-04-2013 11:54 AM)Rabishan Wrote:  after turning off palette mode did you add alpha value in the particle color.

That helped, thanks.

Now I have another question though: when I created and saved a particle system as .particle, how do I add this to a world I made?
02-04-2013 01:01 PM
Find all posts by this user Quote this message in a reply
Rabishan Offline
Member

Post: #4
RE: Particle question
you can check water.world in esenthel. it shows example about how to add particles in world directly through editor.
02-05-2013 12:15 PM
Find all posts by this user Quote this message in a reply
Gian-Reto Offline
Member

Post: #5
RE: Particle question
If I understand this correct: I create an empty .obj outside of EE, open this in the editor and attach the particle system in the editor, then save it, right?

Will test this later on, thanks for the help.
02-05-2013 12:52 PM
Find all posts by this user Quote this message in a reply
Esenthel Online
Administrator

Post: #6
RE: Particle question
latest SDK has small bug that lights and particles are not visible in the Editor (edit mode), will be fixed soon.
It works in game mode though
02-05-2013 02:57 PM
Find all posts by this user Quote this message in a reply
Gian-Reto Offline
Member

Post: #7
RE: Particle question
Somehow I seem to be unable to add the particle effect to the world.

And I did test the built world in my game client, nothing appears. Seems my obj file doesn't contain the particle system. Works with the predefined fire and so on though.

How do I create a particle .obj?
02-06-2013 08:21 AM
Find all posts by this user Quote this message in a reply
Esenthel Online
Administrator

Post: #8
RE: Particle question
I've just reuploaded Editor EXE files for last 1.0 SDK, it should be ok now

for a working sample please open for example "teleport 1.world" from SDK sample worlds in the Editor.
02-06-2013 04:46 PM
Find all posts by this user Quote this message in a reply
Gian-Reto Offline
Member

Post: #9
RE: Particle question
It works now for me, thanks.

Last question: how can I get more fine control over the shape of the particle system (or the emitter in this case)?
02-07-2013 08:14 AM
Find all posts by this user Quote this message in a reply
Esenthel Online
Administrator

Post: #10
RE: Particle question
You can call Particles::source in each frame to specify new shape.
02-19-2013 01:28 PM
Find all posts by this user Quote this message in a reply
Post Reply