About Store Forum Documentation Contact
Donations:
158$/mo



Post Reply 
compiled android apps do not work on my phone
Author Message
dziablo Offline
Member

Post: #1
compiled android apps do not work on my phone
hi, i wanted to build tutorials on my sony xperia e and build is succesful but later instead of app black screen popups for 1 sec then it dissapers and im back in menu. i see nothing wrong in logs but i am newb, ill link them here.

ps. i configured everything like in this wiki article: http://www.esenthel.com/wiki/index.php?t...ndroid_SDK

help me with that please.


Attached File(s)
.txt  Android Device Log.txt (Size: 85.78 KB / Downloads: 2)
.txt  Output.txt (Size: 7.49 KB / Downloads: 2)
12-02-2013 10:57 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #2
RE: compiled android apps do not work on my phone
Hi,

You're using engine lib and engine pak of different versions.
Please update EE 2.0 to latest version.
Are you on Win or Mac?
12-02-2013 11:11 PM
Find all posts by this user Quote this message in a reply
dziablo Offline
Member

Post: #3
RE: compiled android apps do not work on my phone
It's windows and i just reinstalled esenthel engine because i don't know how could i force it to update. There is the same problem but i have new logs. What about this:
Quote:Time(00:07:42), App(Esenthel): Shader Param "ShdMatrix6[5]" not found.
Time(00:07:42), App(ActivityManager): Process com.test.test (pid 3984) has died.


Attached File(s)
.txt  Android Device Log.txt (Size: 85.91 KB / Downloads: 2)
12-03-2013 12:17 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #4
RE: compiled android apps do not work on my phone
What app are you trying to run? your own or some tutorials? Do tutorials work ok?
Do you have any custom shaders? If yes then you need to recompile them.
12-03-2013 12:22 AM
Find all posts by this user Quote this message in a reply
khces Offline
Member

Post: #5
RE: compiled android apps do not work on my phone
latest version update after

I also have the same problem ... and image:drawFs about compile error

D:/Android/android-ndk/toolchains/arm-linux-androideabi-4.6/prebuilt/windows-x86_64/bin/../lib/gcc/arm-linux-androideabi/4.6/../../../../arm-linux-androideabi/bin/ld.exe: ./obj/local/armeabi-v7a/objs-debug/Project/Main.o: in function Draw():jni/../../Source/Main.cpp:40: error: undefined reference to 'EE::Image::drawFs(EE::FIT_MODE, bool) const'
12-03-2013 03:53 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #6
RE: compiled android apps do not work on my phone
Hi,
Thanks for reporting the issue.
I've recompiled the engine, and I'm now reuploading it.
It should be available in ~15 minutes
12-03-2013 05:05 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #7
RE: compiled android apps do not work on my phone
Please restart the Editor so it will check for the update which is now available (on Windows).
12-03-2013 05:19 AM
Find all posts by this user Quote this message in a reply
khces Offline
Member

Post: #8
RE: compiled android apps do not work on my phone
Good thanks!!!!
12-03-2013 07:53 AM
Find all posts by this user Quote this message in a reply
Post Reply