About Store Forum Documentation Contact

Post Reply 
Author Message
MrPi Offline

Post: #1
I can't get the items from the Apple store on iOS.
When I call refreshItems, the callback is executed with the result REFRESHED_ITEMS, but NS.items() is empty.

I've set the Bundle ID in the format "com.MyCompanyName.MyAppName" and registered an app with the same ID on iTunes Connect, where I added 4 in-app purchases with the product IDs "10gems", "50gems" etc..

What else is required to make this work?
When the callback is executed with REFRESHED_ITEMS, does that mean it was successful?
02-28-2014 07:50 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline

Post: #2
RE: NativeStore
Did you specify it that is ready for sale?
Did you upload a screenshot for it?
Quote:Didn’t work? If this didn’t work for you, there are a number of things to check (this list courtesy of itsme.manish and abgtan from the forums:
•Go to Settings\iTunes & App Stores, log out of any account, and try again so you’re sure you’re using a Sandbox account.
•Check this link – if it doesn’t respond, the iTunes sandbox may be down.
•Have you enabled In-App Purchases for your App ID?
•Does your project’s .plist Bundle ID match your App ID?
•Are you using the full product ID when when making an SKProductRequest?
•Have you waited several hours since adding your product to iTunes Connect?
•Are your bank details active on iTunes Connect?
•Have you tried deleting the app from your device and reinstalling?

Tried all that and still stuck? Try the old forum thread or this thread’s comments for discussion with other readers.

Please let us know which suggestion helped to solve this, thanks
02-28-2014 09:22 PM
Find all posts by this user Quote this message in a reply
MrPi Offline

Post: #3
RE: NativeStore
Alright, I got it working now. My bank and legal details weren't in effect yet.
03-01-2014 03:29 PM
Find all posts by this user Quote this message in a reply
Post Reply