About Store Forum Documentation Contact
Donations:
309$/mo



Post Reply 
Texts don't show
Author Message
Pherael Offline
Silver Supporter

Post: #1
Texts don't show
One of our player have this problem:



https://www.youtube.com/watch?v=obeZZO_J8Gg

As I know, so far only one person have this problem. Reinstalling the game from steam does not help. He say his drivers are updated. Any idea what could be source of problem and how to fix it?
(This post was last modified: 09-18-2019 08:55 AM by Pherael.)
09-18-2019 08:54 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #2
RE: Textes don't show
What's the computer's GPU?
This is most likely a graphics card driver bug.
09-18-2019 11:05 AM
Find all posts by this user Quote this message in a reply
Pherael Offline
Silver Supporter

Post: #3
RE: Textes don't show
GPU: sapphire radeon rx 5700 xt pulse 8 gb

CPU: amd ryzen 5 3600
Motherboard: msi b450 gaming plus
RAM: crucial ballistix sport LT 8gb x2
Drive: adata ssd xpg sx6000 pro 512gb
System: windows 10 pro version 1809
09-18-2019 11:09 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #4
RE: Textes don't show
It looks like not only texts have problem, but 3d has issues too, alpha test doesn't work on plants (ferns, tree leafs), and trees don't cast shadows (except bark).
09-18-2019 11:19 AM
Find all posts by this user Quote this message in a reply
Schlabach Offline
Member

Post: #5
RE: Textes don't show
Is it possible to somehow add the shadows separately?
10-04-2019 01:57 PM
Find all posts by this user Quote this message in a reply
Pherael Offline
Silver Supporter

Post: #6
RE: Textes don't show
I wanted add that two more people reporting this problem (RADEON RX VEGA 56 and Radeon RX 5700 XT). Both people using drivers version 19.9.2
It may be issue with AMD cards or drivers.
(This post was last modified: 10-07-2019 02:47 PM by Pherael.)
10-07-2019 09:56 AM
Find all posts by this user Quote this message in a reply
Pherael Offline
Silver Supporter

Post: #7
RE: Textes don't show
After many testes, it's looks that Esenthel don't work with some AMD cards. Not only my game don't work on RADEON RX VEGA 56 and Radeon RX 5700 series, but also Esenthel Editor. There problems with font, some textures and shadows.
(This post was last modified: 10-23-2019 08:40 AM by Pherael.)
10-23-2019 08:40 AM
Find all posts by this user Quote this message in a reply
Zervox Offline
Silver Supporter

Post: #8
RE: Textes don't show
can confirm, after upgrading from RX570 to 5700 today, editor is not rendering text for projects and elements etc, code viewer still renders properly.

Driver version 19.10.1 and 19.9.2 tested same problem. RX570 renders normally.
10-23-2019 07:32 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #9
RE: Textes don't show
Could anyone with an AMD card affected by this problem check if this commit fixes the issue?
https://github.com/Esenthel/EsenthelEngi...d6d3082aa1

Basically just have to replace:
static Byte VS_Code
inside Engine/Source/Graphics/Vertex Index Buffer.cpp
and rebuild the engine
10-25-2019 01:14 PM
Find all posts by this user Quote this message in a reply
Zervox Offline
Silver Supporter

Post: #10
RE: Texts don't show
I will check once I get back home from work.

Well building the engine and the Esenthel builder and running the builder shows the same as current release, text not working on 5700
(This post was last modified: 10-25-2019 07:27 PM by Zervox.)
10-25-2019 07:07 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #11
RE: Texts don't show
Thank you Zervox for testing.
I'm in touch with some friendly folks at AMD so I hope we'll be able to find some solution.
10-26-2019 03:16 AM
Find all posts by this user Quote this message in a reply
RedcrowProd Offline
Bronze Supporter

Post: #12
RE: Texts don't show
ye seems that i am having the same issue with my test laptop that runs AMD as well. : /
10-27-2019 08:38 PM
Find all posts by this user Quote this message in a reply
notmyaccount Offline
Member

Post: #13
RE: Texts don't show
i try your solution and now i have other error:
- D3D11 ERROR: ID3D11Device::CreateShaderResourceView: The Format (0x1c, R8G8B8A8_UNORM) is invalid, when creating a View; the Resource was already created with a fully qualified Format, which is not castable (0x1d, R8G8B8A8_UNORM_SRGB). [ STATE_CREATION ERROR #127: CREATESHADERRESOURCEVIEW_INVALIDFORMAT]
- D3D11 ERROR: ID3D11Device::CreateShaderResourceView: Returning E_INVALIDARG, meaning invalid parameters were passed. [ STATE_CREATION ERROR #131: CREATESHADERRESOURCEVIEW_INVALIDARG_RETURN]
(This post was last modified: 10-28-2019 01:56 PM by notmyaccount.)
10-28-2019 01:56 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #14
RE: Texts don't show
That error is irrelevant (you can ignore it)
10-28-2019 03:16 PM
Find all posts by this user Quote this message in a reply
notmyaccount Offline
Member

Post: #15
RE: Texts don't show
ok, but the problem still occurring

and I still have this error:
-DXGI WARNING: IDXGIFactory::CreateSwapChain: Blt-model swap effects (DXGI_SWAP_EFFECT_DISCARD and DXGI_SWAP_EFFECT_SEQUENTIAL) are legacy swap effects that are predominantly superceded by their flip-model counterparts (DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL and DXGI_SWAP_EFFECT_FLIP_DISCARD). Please consider updating your application to leverage flip-model swap effects to benefit from modern presentation enhancements. More information is available at http://aka.ms/dxgiflipmodel. [ MISCELLANEOUS WARNING #294: ]
(This post was last modified: 10-28-2019 03:25 PM by notmyaccount.)
10-28-2019 03:22 PM
Find all posts by this user Quote this message in a reply
Post Reply